rakumo Sync 状況: 復旧済み
一部の予定が同期されない事象が発生

rakumo Sync 状況: 復旧済み
一部の予定が同期されない事象が発生

平素よりrakumoをご利用くださいまして誠にありがとうございます。
rakumoサポートでございます。

rakumo Sync において、下記の事象が生じておりました。
お手数でございますが、ご確認くださいますようお願いいたします。

障害情報詳細

【発生日時】

2018年 6月 5日

【サービス】

rakumo Sync

【内容】

・ Google カレンダーで複数人の参加者を含む予定を登録したとき、一部の予定が Salesforce のカレンダーに同期されないエラーが発生
エラー原因 : API 経由で行動を作成したとき、行動のカスタム項目がユニーク制限に抵触してエラーが発生しています。

<エラー例>
"errorCode": "DUPLICATE_VALUE",
"message": "duplicate value found: unknownの値が重複しているレコードの ID:
xxxxxxxxxxxxxxx"

※ 上記操作をしたとき、正常に同期される Salesforce 組織と、今回のエラーが発生する Salesforce 組織がございます。
お手数でございますが、次の [1] と [2] をご確認くださいますようお願いいたします。

[1] rakumo Sync Setup 画面の 「ログの閲覧画面」 で確認できるエラー内容
- ログレベル  Error
- メッセージ  予定 〇〇〇 は同期できません。 〇〇〇 ・・・ 予定のタイトルが入ります
- エラー種別 SalesforceApiError (Conflict)
- APIのレスポンス "duplicate value found: rakumosync__SyncId__cの値が重複しているレコードの ID: xxxxxxxxxx"  xxxxxxxxxx ・・・ 文字列が入ります

[2] お客様の Salesforce 環境でエラー発生の有無を確認する方法
Salesforce の行動のページレイアウトに 「Sync ID」 を設置します。行動の作成画面で 「Sync ID」 に任意の値を入力して、新規行動を保存したタイミングでエラーが出る時は、上記 "エラー状況" に記載する状況が生じています。

【原因】

本エラーに関しましては、rakumo Sync のインストール有無にかかわらず発生する Salesforce の障害と判明いたしました。

状況

【復旧済み】2018年6月25日 13時00分 --------------------------------------------
本エラーの原因となった不具合につきまして、Salesforce 社にて改修ならびに恒久対処策を実施済みです。
現在は、同様の事象は発生しておりません。

このたびはお客様へご迷惑をお掛けしましたこと、ならびに改修までお時間をいただきましたこと深くお詫びを申し上げます。
今後も Salesforce と連携を取り、サービスの向上に努めて参りますため、何とぞよろしくお願い申し上げます。

【発生中】2018年6月12日 13時00分 --------------------------------------------
内容と原因を追記しました。
本エラーに関しましては、rakumo Sync のインストール有無にかかわらず発生する Salesforce の障害と判明いたしました。
つきましては、現在 Salesforce 社へ早急な改修対応を依頼しております。
回避策ならびに状況の進捗に関しましては、判明次第お知らせしてまいります。
Salesforce サポートと連携を取り、調査を行っております。

お客様には大変なご迷惑をおかけしておりますこと、深くお詫びを申し上げます。
大変恐縮ではございますが、どうか引き続きお時間をくださいますようお願いいたします。

【発生中】2018年6月6日 17時30分 --------------------------------------------
エラー内容から、Salesforce 側の仕様変更、もしくは不具合によって本事象が生じている可能性が高いため、弊社から Salesforce へ早急な調査と対応を要求しております。
お客様には大変なご迷惑をおかけしておりますこと、深くお詫びを申し上げます。
大変恐縮ではございますが、どうか引き続きお時間をくださいますようお願いいたします。

【発生中】2018年6月6日 9時30分 --------------------------------------------
お客様には大変なご迷惑をおかけいたしまして、誠に申し訳ございません。
現在、Salesforce サポートと連携を取り、事象の究明に向けて調査中でございます。
大変恐縮ではございますが、調査完了までお時間をくださいますようどうかお願いいたします。

【発生中】2018年6月5日 18時10分 --------------------------------------------
お客様にはご迷惑ならびにご不便をおかけいたしまして、誠に申し訳ございません。
現在、本事象の原因につきまして調査を行っております。進捗を随時ご連絡いたしますので、今しばらくお時間をくださいますようお願いいたします。

お客様にはご迷惑ならびにご不便をおかけいたしまして、誠に申し訳ございません。

本件につきまして、ご不明な点がありましたら、お問い合わせフォームよりお知らせくださいませ。

どうかよろしくお願い申し上げます。

2018年6月5日
rakumo サポート担当